报错提示:

        每次systemctl restart docker,会发生nacos秒启动,但是服务未完全准备好的情况,IDEA连接容器会报错

修复方法:

docker-compose.yml文件中

nacos:
    image: nacos/nacos-server:v2.3.2
    container_name: powerguard-nacos
    restart: always
    environment:
      MODE: standalone
      JVM_XMS: 512m
      JVM_XMX: 512m
      JVM_XMN: 256m
    ports:
      - "8848:8848"
      - "9848:9848"
    volumes:
      - nacos_logs:/home/nacos/logs
    depends_on:
      redis:
        condition: service_healthy

healthcheck:                          # ★ 新增健康检查
      test: ["CMD", "curl", "-f", "http://localhost:8848/nacos/"]
      interval: 5s
      timeout: 5s
      retries: 20
      start_period: 30s

    networks:
      - powerguard-net

# ★ 新增健康检查 可以帮助排查nacos是否健康启动问题,保证服务正常运行

nacos官网:www//localhost:8848/nacos

        导入修改好的服务的.yaml文件

导入时会发现自己压缩的zip文件无法识别的问题

        解决方法:一次在www//localhost:8848/nacos配置修改好后,选择所有需要的文件,导出

        下次导入直接导入这个导出文件即可完成nacos设置。

更多推荐