云主机VNC报错 fork:cannot allocate memory ,也无法SSH

查找解决办法,发现大部分都是因为现有的进程数超过系统设置最大进程数
开始排查:

  1. 重启系统然后SSH连接(刚启动进程少是可以连上的),查看系统设置的最大进程数:
sysctl kernel.pid_max
  1. 查看现在运行的进程数:
ps -eLf | wc -l
  1. 如果现有的进程数超过或者接近系统设置的最大进程数,把系统最大进程数调高到合适的数量:
echo "kernel.pid_max=500000 " >> /etc/sysctl.conf
sysctl -p #应用之前的设置 
  1. 如果是觉得自己的主机不应该突然会有这么多的进程,那就需要排查是否有被黑入的可能,排查怪异的进程和登入日志。

更多推荐