create  profile qcprofile limit sessions_per_user 200; 
alter user qcloud profile qcprofile;

在这里插入图片描述

select username, profile from dba_users where username='QCLOUD';

在这里插入图片描述

alter profile qcprofile limit sessions_per_user 300;

select resource_name, limit from dba_profiles where profile='QCPROFILE';

在这里插入图片描述

不执行的话没效果。。。

alter system set resource_limit=true;

限制每个user能登录的最多会话数,如果没启用资源限制的话,那这个参数即使设置了也不会生效的。(修改配置后)
在这里插入图片描述

超过上限会报错如下

在这里插入图片描述

更多推荐