前言

对linux服务器的服务进行压测时,服务器的运行情况可以通过添加插件serverAgent来观察,可以实时监控性能指标

操作步骤

下载插件

客户端插件:jmeter-plugins-perfmon-2.1.jar
  • 安装plugins manager
  • 下载地址:https://jmeter-plugins.org/install/Install
  • 安装方式:下载jar包 -> lib/ext -> 重启jmeter
    在这里插入图片描述
  • 安装jmeter-plugins-perfmon-2.1.jar
    • 路径:选项 -> plugins-manager -> Availabel Plugins,搜索PerfMon
    • 点击安装,安装成功后重启
      在这里插入图片描述
服务端插件:ServerAgent-2.2.3
  • 下载地址:https://github.com/undera/perfmon-agent/blob/master/README.md

  • 安装配置方式如下:

    > # 把下载的服务端插件ServerAgent上传到待监控的虚拟机任一目录
    > scp  ServerAgent-2.2.3.zip  root@ip:/home/temp
    > # 解压 插件
    > unzip ServerAgent-2.2.3.zip
    > # 进入解压的目录,启动服务插件
    > cd ServerAgent
    > ./startAgent.sh 
    
  • 若是启动失败,按如下方式排查

    > # 检查防火墙的状态
    > systemctl status firewalld
    > # 若防火墙是开启的,则检查端口是否开放
    > firewall-cmd --query-port=4444/tcp
    > # 若未开放端口,则开放端口
    > firewall-cmd --zone=public --add-port=4444/tcp --permanent
    > # 重启防火墙
    > systemctl restart firewalld.service
    > # 如果4444端口被占用,则更换端口4445
    > ./startAgent.sh --udp-port 0  --tcp-port 4445
    > # 后台启动方式
    > nohup ./startAgent.sh --udp-port 0  --tcp-port 7071 >> nohup.out 2>&1 &
    > ###### 一定记住 #######
    > 云上某个端口无法开发,不要纠结,换个端口试试,一定要换个端口试试,zzzzzzz
    
  • 安装依赖插件

    > apt install unzip
    > apt install default-jre
    

参考博客

  1. https://blog.csdn.net/weixin_35342955/article/details/114674545
  2. https://blog.csdn.net/cae_520_ww/article/details/120623177
  3. https://blog.csdn.net/whataryou/article/details/121804646
  4. https://blog.csdn.net/qq_43023590/article/details/124372333
  5. https://www.cnblogs.com/yoyoketang/p/14186997.html

更多推荐