hadoop3.X启动yarn报错:ATTEMPTING TO OPERATE ON HDFS NAMENODE AS ROOT(start-all.sh)启动失败解决方法
·
最近装了hadoop3.X版本集群,感觉相对比2.X版本有很多坑
在完成集群配置后,启动hdfs.sh和yarn.sh都遇到这个问题了

解决问题方法:
需要修改
start-dfs.sh
stop-dfs.sh
start-yarn.sh
stop-yarn.sh
配置sbin下的start-dfs.sh添加
HDFS_DATANODE_USER=root
HADOOP_SECURE_DN_USER=hdfs
HDFS_NAMENODE_USER=root
HDFS_SECONDARYNAMENODE_USER=root
配置stop-dfs.sh添加
HDFS_DATANODE_USER=root
HADOOP_SECURE_DN_USER=hdfs
HDFS_NAMENODE_USER=root
HDFS_SECONDARYNAMENODE_USER=root
配置sbin下的 start-yarn.sh添加
YARN_RESOURCEMANAGER_USER=root
HADOOP_SECURE_DN_USER=yarn
YARN_NODEMANAGER_USER=root
配置sbin下的stop-yarn.sh 添加
YARN_RESOURCEMANAGER_USER=root
HADOOP_SECURE_DN_USER=yarn
YARN_NODEMANAGER_USER=root
配置vi /etc/selinux/config
将修改SELINUX=enforcing更改为SELINUX=disabled
最后将其重新复制到其他节点,然后启动hadoop就行了
更多推荐



所有评论(0)