hbase启动后HMaster进程自动关闭,hadoop:9000 failed on connection exception.
2021-05-19 12:00:43,885 FATAL [hadoop102:16000.activeMasterManager] master.HMaster: Failed to become active master
java.net.ConnectException: Call From hadoop102/192.168.10.102 to hadoop102:9000 failed on connection exception: java.net.ConnectException: 拒绝连接; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused
2021-05-19 12:00:43,886 FATAL [hadoop102:16000.activeMasterManager] master.HMaster: Unhandled exception. Starting shutdown.
java.net.ConnectException: Call From hadoop102/192.168.10.102 to hadoop102:9000 failed on connection exception: java.net.ConnectException: 拒绝连接; For more details see: http://wiki.apache.org/hadoop/ConnectionRefused
运行hbase时发生的异常,hbase启动几秒后自杀
原因是hadoop的core-site.xml中默认端口号(8020)与hbase-site.xml中写的(9000)不同,修改成相同既可
先查看hdfs的默认端口号
[artemis@hadoop102 logs]$ cd /opt/module/hadoop-3.1.3/etc/hadoop
[artemis@hadoop102 logs]$ vim core-site.xml

再去修改hbase配置文件中hdfs的默认端口号,我原来写的是9000,改成8020
[artemis@hadoop102 hadoop]$ cd /opt/module/hbase-1.3.1/conf
[artemis@hadoop102 hadoop]$ vim hbase-site.xml

启动hmaster
[artemis@hadoop102 hadoop]$ bin/hbase-daemon.sh start master
[artemis@hadoop102 hadoop]$ jps

恢复正常
更多推荐



所有评论(0)