目录

问题现象:

问题分析:

解决方法:


问题现象:

今天在用mybatis的mapper.xml方式写完分页查询的sql语句后,如图:

在访问对应的的接口时出现报错:

在IDEA的控制台可以看见报错信息:

显然错误原因是:PSQLException: ERROR: LIMIT #,# syntax is not supported


问题分析:

可以看到这里的报错类型是PSQLException,也就是说是postgresql数据库识别到的这个错误:

从报错后给出的建议,就可以知道问题所在:

是因为 sql语句中的"LIMIT #,#"无法识别!

为什么呢?

是因为 LIMIT #{offset},  #{pageSize} 是属于mysql的用法,而我平时用惯了mysql数据库,所以在使用postgresql数据库时,并不清楚它的sql语句规范(我也是第一次使用postgresql数据库哈哈哈)

而postgresql中的分页sql是 LIMIT #{pageSize} OFFSET #{offset} .


解决方法:

        解决方法很简单就是把报错的 LIMIT #{offset},  #{pageSize} 改为 postgresql 格式的sql语句即可,如下:LIMIT #{pageSize} OFFSET #{offset}

将mysql格式下的limit分页语句:

改为postgresql 格式的sql语句即可。

更多推荐