1.问题重述

MySQL版本:8.4.0

SQlyog连接到主机时报错:错误号码2058Plugin sha256 password could not be loaded,如下图

经过查阅资料得知出现这个问题是因为 mysl8之前的加密规则是 mysql_native_password ,而在mysql8之后,加密规则是caching_sha2_password

2.解决方案:

(1)升级SQLyog-图形化工具

帮助→检查更新,然后前往官网自行下载

(2)把mysql用户登录密码加密规则还原mysql_native_password。

解决步骤如下:

1.以管理员身份打开终端,输入:

mysql -u root -p

输入自己的密码:

2.把 MySQL8 用户登陆密码加密规则还原成 mysql_native_password,输入以下内容:

alter user 'username'@'host' identified with mysql_native_password by 'yourpassword';

记得把yourpassword改成你自己的密码嗷

即可完美解决问题

更多推荐