由于本人记忆力较差,总是忘记Mysql数据库密码,使用Navicat连接时总会报错,所以在这里记录一下。

 这边采用修改数据库密码的方式:

1.首先用管理员身份运行命令提示符,输入  net stop mysql    停止mysql服务。

2.cd 至mysql的bin目录下,输入如下命令,跳过密码进入mysql

mysqld --console --skip-grant-tables --shared-memory

3.运行完不要关闭此窗口。重新以管理员身份打开另一个命令提示符窗口,输入如下指令:

mysql -u root -p

输入密码处,直接回车。

 4.进入mysql数据库,重新设置密码

#进入数据库
use mysql
#重新设置密码
update mysql.user set authentication_string=password('root') where user='root'
#刷新数据库
flush mysql
#退出
quit

5.重新启动mysql

net start mysql

6.连接。

更多推荐