问题:

DBeaver连接MySQL时提示:Unable to load authentication plugin 'caching_sha2_password'.
原因:mysql8之前的版本使用的密码加密规则是mysql_native_password,但是在mysql8则是caching_sha2_password,所以需要修改密码加密规则。

解决办法:

1.打开管理员cmd
2.mysql -u root -p后输入密码,进入 myqsql客户端
在这里插入图片描述

3.输入use mysql回车
在这里插入图片描述
4. 输入select user,host,plugin,authentication_string from user;
可以看到如下界面
在这里插入图片描述
5.输入alter user 'root' @'localhost' identified with mysql_native_password by '123456';(其中123456记得替换为你自己的密码)
在这里插入图片描述
运行完毕后再次打开DBeaver连接成功

更多推荐