ERROR 1045 (28000): Access denied for user ‘root‘@‘localhost‘ (using password: NO)
·
数据库报错:ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO),这个错误是因为在修改数据库或者创建数据库的时候数据库密码为空了,这种错误一般可能是改数据库密码时冲突造成的,结果你不知道,就一直在尝试密码登录。
解决办法:
情况一:新创建数据库,终端登录
mysql -uroot -p
回撤直接进入数据库
set password='你的密码';
flush privileges;
情况二:在修改数据库root权限等问题的时候造成的数据库冲突,造成了密码无法登录。
打开mysql的配置文件,my.ini文件。在[mysqld]下加入skip-grant-tables
重启mysql服务,来一次情况一的流程。
更多推荐


所有评论(0)