Mysql5.7安装好后,系统会自动分配一个密码,在使用该密码登陆时会报错,折腾了好久终于解决这个问题了。下面是解决步骤

1. 首先修改Mysql的配置文件,我的是my.ini。在[mysqld]下面加入

skip-grant-tables


2. 启动Mysql服务,并登陆

net start mysql

登陆Mysql,这里输入系统分配的初始密码


3. 修改密码,通过以下命令初始密码

首先输入

flush privileges;

然后修改密码

set password for 'root'@'localhost' = password('mypassword');

看下效果,修改成功。修改成功后使用exit退出mysql, 使用 net stop mysql 关闭mysql服务。


4. 还原my.ini文件

将my.ini中的skip-grant-tables删除, 保存my.ini。然后启动mysql,然后登陆,输入修改后的密码就可以进入了


原因:flush privileges的中文意思是刷新权限,mysql新设置用户或更改密码需用flush privileges刷新MySQL的系统权限相关表,否则会出现拒绝访问。


PS. Python 使用Mysql教程:

1. 首先安装 pymysql

pip install pymysql

2. 链接数据库

import pymysql

db = pymysql.connect(host='localhost', user='root', password='mypassword', port=3306)
cursor = db.cursor()
cursor.execute('CREATE DATABASE IF NOT EXISTS pythonDB DEFAULT CHARSET utf8 COLLATE utf8_general_ci;')
cursor.close()          # 先关闭游标
db.close()              # 再关闭数据库连接
print('创建pythonBD数据库成功')

 

更多推荐